Voici une description de mon installation domestique, telle qu'ele a évolué au fil du temps...

Première installation : Ca a commencé avec l'abonnement ADSL, quand un collègue m'a fait découvrir IPCop...

A l'entrée de chez moi, au bout du fil de téléphone, quoi, y'avait le modem.
C'etait un modem Ethernet. C'est plus régulier et fiable, m'a-t-on dit. Et aussi, ça demande trois fois rien au PC qui le pilote, contrairement à l'USB, où le PC fournit le courant d'alimentation (première source d'ennuis des modems USB) et de la puissance CPU.

J'ai commencé avec un vieux gros ECI Hifocus, le même que fournissait Wanadoo au début à ceux qui étaient sur des "plaques ECI" (au temps préhistorique où tous les Dslams n'étaient pas compatibles !). Puis, avec le dégroupage, il n'a plus voulu faire.

Je suis passé au Bewan ST. Cependant, ce dernier se bloquait parfois, sans que la lecture des forums, pas plus que les communications avec mon FAI ou Bewan SAV ne m'ait permis ni de comprendre pourquoi, ni d'y remédier. Seule solution: aller manuellement débrancher-rebrancher son alimentation pour le réinitialiser ! Finalement, nous avons conçu un bidule electronique pour le faire automatiquement !
NEW ! en Avril 05 le support de Bewan fournissait confidentiellement un nouveau firmware, avec noyau linux, qui corrigeait le problème... Je l'ai mis à disposition là. En Décembre 05, une version publique de ce firmware était enfin disponible sur leur site !

Après le modem, et le pilotant, il y avait… un vieux PC, sur lequel tournait IPCop, une distribution Linux spécialisée, qui joue le rôle de routeur-pare-feu évolué, sécurisant ainsi très efficacement mon système local.

C'est alors un Compaq Deskpro, Pentium 200, 128Mo de Ram EDO, un disque de 1,2Go, sans clavier ni écran (inutiles une fois le système installé), avec deux cartes réseau (de vieilles ISA, car 10 base T suffit pour le flux internet) plus le réseau intégré à la carte mère (en 100, celui-là, pour le réseau interne). L'intérêt de cette plate-forme : ses 8 slots permettant d'utiliser de nombreuses barrettes EDO de faible capacité...
En fait, il a longtemps marché avec Pentium 166, 96Mo de Ram, disque de 425Mo. Je l'ai boosté ensuite pour qu'il filtre aussi mes mails grâce à CopFilter!

Là, deux sorties:

- mon réseau "vert", (réseau privé) sur lequel sont installés plusieurs PC et Mac, par l'intermédiaire d'un switch 8 ports (en 100).
- mon réseau "orange", ou DMZ, où se trouve le serveur "lurey-cadet".
Ces deux réseaux étaient sécurisés différentiellement par IPCop, puisque l'accès au serveur doit être possible plus que celui à mon réseau privé, jalousement gardé…
Je ne vous décris pas les configurations présentes sur le réseau vert, c'est du classique (Windows divers, Mac Os 9 et X de mon voisin, Linux…) et c'est changeant selon le moment et les PC bricolés (du 486 à l'Athlon XP, au temps des débuts de l'installation), tous faits de récupérations et de pièces d'occase….

Le premier serveur "lurey-cadet" est un PC fait de vieilleries montées dans un boîtier desktop AT exotique: processeur K6-2 à 450Mhz, 192Mo de SDRam, carte réseau Ne2000, sur une carte mère DCS S7ax défectueuse : elle ne prend plus le clavier que de temps en temps, juste en début de démarrage, et pas complètement ! je suis arrivé à mettre tout par défaut en reconnaissance automatique dans le bios, et en démarrage sans clavier ("halt on errors: none" dans le bios!)

Pour mes premiers pas avec la distribution SME, j'avais monté mon serveur sur un disque de 2,1 Mo. Par la suite, j'en ai ajouté un de 40Go sur lequel j'ai fait migrer tous les espaces de stockage de mon serveur, gardant l'essentiel du système en place sur le "petit" premier : je n'ai pas voulu tout réinstaller à cause du problème de la carte mère…

J'avais fait l'installation initiale de SME sur un autre PC avec le même processeur et un chipset identique, ( c'est paraît-il indispensable pour que l'installation du noyau Linux soit adéquate !) insérant les même cartes réseau et vidéo dans les mêmes slots ; puis j'ai transféré cartes et disque sur ma machine « manchote », connectée au réseau … ensuite, tout se fait par console à distance, avec Putty (en SSH) ! C'est comme ça que j'ai ensuite ajouté le deuxième disque et modifié les paramétrages nécessaires, grâce aux connaissances acquises sur les forums d'Ixus et sur le site de Grand'Pa.

En Novembre 06, après plus de deux années de bons et loyaux services, j'ai fait un premier upgrade de mon serveur : ayant décidé d'installer la nouvelle version 7 de SME, je l'ai fait sur un materiel modernisé (...!) à savoir que système et stockage sont désormais installés sur deux disques durs SCSI , la distribution SME proposant un RAID logiciel (RAID 1 dans mon cas). J'ai trouvé pour cela, presque neuf (...!), une carte Adaptec AHA-2940 UW, et deux disques Fujitsu 18,2 Go - 10000 tr/mn.

Pendant trois bonnes années, j'ai donc utilisé deux petites configurations qui assumaient distinctement l'une les tâches de firewall-routeur (IPCop) l'autre celles du serveur lurey-cadet.
Deux éléments qui ont participé à l'évolution de mon dispositif :
- ma "découverte" du SCSI, dont j'attendais dans un premier temps une gestion meilleure des disques durs, apportant de meilleures performances (vitesses de traitement, installation en RAID) tout en demandant moins au CPU (c'est la carte SCSI qui gère).
- mon goût pour les choses récupérés - le premier serveur était déjà une machine "rescapée", montée sur une carte mère défectueuse, avec des pièces de récupération...


Le soucis de réduire l'encombrement et le bruit dans mon garage, ainsi que la consommation d'électricité, m'ont amené à envisager d'utiliser la distribution SME pour assumer l'ensemble des tâches sur une seule machine... ceci supposait cependant une configuration un peu plus puissante que mon vaillant K6-2 ! Ainsi est née la deuxième version du serveur lurey-cadet, sur lequel SME sera donc installé en serveur et passerelle, dans sa version 7.

Constitué autour de la carte mère défectueuse d'un ordi de grande surface - qui ne gérait plus ses disques IDE - échappée de la poubelle grâce à une carte SCSI qui pilote les deux disques durs (en RAID logiciel, fourni par SME, pour éviter toute perte de données), je l'ai doté du moins cher des processeurs que j'ai trouvé d'occase en socket 478 : un Céléron 2Ghz , adossé à 256 Mo de DDR.
Cette config dépassait très largement les performances de mon installation précédente, et a trouvé place dans un petit boitier (du HP, de la marque...!) dont l'alimentation de 145 W semblait suffire !

Peu à peu, mon serveur a bénéficié d'upgrades matériels, au fil des occasions ; ainsi, les disques sont passés de 18 à 36Go, tandis que les sites hébergés tendaient à prendre de l'embonpoint ! La Ram a été augmentée également...

Ce boitier mini-tour était peu encombrant, mais peu commode par terre dans mon garage, alors qu'avant, le premier desktop accroché-plaqué au mur "dégageait le plancher".

L'occasion faisant le laron, j'ai récupéré un boitier plat peu encombrant et assez silencieux... de la marque encore !
Ce Dell Optiplex a été l'occasion d'un nouveau bon technologique, je l'ai équipé d'un P4 2,4Ghz, de 1024Mo de DDR, et d'une carte SCSI Adaptec Ultra2wide - en fait, cette carte à 80Mb/s avait depuis quelques mois remplacé la -UW (40Mb/s)sur la configuration précédente. Nouvelle inflation côté disques : deux unités de 146 Go, toujours en "mirroir" (RAID 1) car j'ai commencé à sauvegarder dessus des fichiers volumineux, enregistrements sons et surtout mes photos (avec un système "home-made", en php, de visionneuse et administration des albums...)

Le passage à la version 8 de SME a été l'occasion de tout réinstaller au propre ("from scratch"), et ainsi de ne transférer que l'utile en nettoyant toutes les traces d'essais et utilisations devenues inutiles ou obsolètes... par la même occasion, installation d'une carte Adaptec 29320 récupérée entre temps (...toujours plus vite ! pas indispensable, mais la U2W me sert sur une machine d'essai)
Mais le système de sécurisation par htaccess (mis en place pour l'administration des albums photos) m'a causé des soucis après l'upgrade en v.8 ; ceci fut l'occasion de découvrir le forum de contribs.org consacré à la distribution SME - qui prend pour nom KOOZALI SME Server - alors que celui de Ixus.net, première source de mes apprentissages, semble connaitre un certain déclin...

 

page d'accueil